System Requirements

 

The Philips Online Learning Center offers training designed to effectively educate hospital staff on the use of Philips medical equipment and clinical topics. To ensure a learning experience that is as smooth as possible, please review the following system requirements:

IT ENVIRONMENT

  • The system uses ports 80 and 443 for www.theonlinelearningcenter.com
  • Adobe Connect is used by the system and requires the use of ports 443, 1935 and 80 RTMP
  • None of the ports used by the system should be throttled down
  • Email is sent to users by the system from the info@theonlinelearningcenter.com address. The address must be included in the trusted list of email senders to ensure messages are received and not flagged as spam or phishing emails
  • Proxy changes may be required to allow users to view Philips webinars

USER SYSTEMS

  • PC or Mac with a broadband internet connection
  • Browser Compatibility:
  • Microsoft Internet Explorer 11 (previous versions are not supported)
  • Microsoft Edge (for Windows 10)
  • Google Chrome (latest version)
  • Mozilla Firefox (latest version)
  • NOTE: Safari is not supported

Plug-ins

When launching a module, the browser may alert the user if a plug-in must be installed in order to properly view the module content. One or more of the following plug-ins may be required:

  • Adobe Reader
  • Adobe Flash Plug-in
  • Windows Media
  • Real Media Player

Download a PDF copy of the system requirements.